No sale elemento cuando se entra en ADE, OpenCMS

Si os deja de aparecer un elemento que introduzcais en el ADE, aunque existen multitud de causas (como revisar el formateador, los DIVs, los CSS, normalmente la causa principal es haber metido dentro un DIV de limpieza.

Es decir, no es conveniente ni por diseño ni por estructura meter en el formateador el tipico DIV con el siguiente estilo:

float: none;
clear: both;
border-style: none;

Ya que al eliminar el float y con el clear el ADE no funciona, vamos, que esconde el elemento si el formateador incluye algo que haga esto justo despues de dibujar la página.

Problemas con los permisos en los directorios creados por apache

Hoy nos hemos encontrado con el problema de que apache crea directorios con permisos solo 750, a pesar de poner un 777 en el mkdir desde php. Se solucionaría con un umask antes del mkdir, pero nos restringiría las aplicaciones como wordpress, y tampoco nos interesa un script que cambiase los permisos por las noches, así que hemos estado un rato buscando la solución.

En nuestro Centos del servidor, tras mucho indagar, y cambiar el .profiles del usuario apache sin ningún resultado, hemos visto que la solución está en editar /etc/sysconfig/httpd añadiendo a final un «umask 0002» y reiniciar el apache. A partir de entonces crea los directorios con un 770 sin problemas.

Espero que os ayude!!

Problemas con la fecha en php

Si os aparece el error «PHP Warning:  date(): It is not safe to rely on the system’s timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected ‘Europe/Berlin’ for ‘CEST/2.0/DST’ instead in» que me he encontrado en el php 5.3 se soluciona modificando en el php.ini tenemos que poner nuestra fecha por defecto:


[Date]
; Defines the default timezone used by the date functions
; http://www.php.net/manual/en/datetime.configuration.php#ini.date.timezone
date.timezone = "Europe/Berlin";